Raspberry Pi 3 B: Bedeutung der Status LEDs

Der Raspberry Pi 3 B hat 2 Status LEDs:

1. PWR-LED

Die rote Status LED (PWR-LED) zeigt den Zustand der Stromversorgung an. Wenn sie ununterbrochen rot leuchtet, liegt eine Spannung von ca. 5 Volt am Raspberry Pi an, es kann mit dem Raspberry Pi gearbeitet werden. Sollte die LED anfangen zu blinken, so ist die Spannung unter 4,63 Volt gefallen. Die LED leuchtet auch, wenn der Raspberry Pi ausgeschaltet ist.
Sollte die PWR-LED blinken liegt also meistens ein Problem mit der Spannungsversorgung an, als erstes sollte somit das Netzteil geprüft werden. Weiter unter steht noch eine weitere Erklärung.

2. ACT-LED

Die grüne Status LED (ACT-LED) zeigt den Zugriff auf die SD-Karte an. Bei jedem Zugriff (Lesen und Schreiben) auf die SD-Karte blinkt diese LED grün. Wenn die ACT-LED dauerhaft grün leuchtet, dann kann nicht auf die SD-Karte zugegriffen werden, bzw. nicht auf das Image. Es kann also sein, dass keine SD-Karte vorhanden ist, dass sie leer oder defekt ist oder dass es kein Bootbares Image auf der Karte gibt.

UPDATE 06.03.2019

Wenn die LEDs in Mustern anfangen zu blinken kann das verschiedene Ursachen haben, hier folgt eine kleine Übersicht über Muster und deren Ursache:

Grüne LED:
3x blinken: start.elf nicht vorhanden
4x blinken: start.elf nicht gestartet (SD-Karte kann auch defekt sein)
7x blinken: kernel.img nicht vorhanden
8x blinken: SD nicht erkannt. Evtl. hilft ein Update der bootcode.bin oder start.elf

Rote LED:
4x langes blinken, 4x kurzes, 1x sehr lang: Image kann nicht erkannt werden, ein Neuaufspielen des Image schafft Abhilfe.

Kategorien: Raspberry Pi

5 Kommentare

WP · 1. März 2019 um 11:09

Das Blinken der roten LED 4x Kurz, 4x lang ist ein Problem eines falschen / zu alten Images und NICHT der Stromversorgung!!!
An 3 verschiedenen Pi3 nacheinander getestet – wollte die schon als defekt rauswerfen, weil es immer nur „Netzteil“ heisst …
Ein aktuelles Image aufgespielt – und es läuft „normal“ mit allen 2,5A – Netzteilen im Haus …

    Holger · 16. März 2019 um 15:38

    Ich kann das auch bestätigen: nachdem ich die ersten beiden Platinen zurückgeschickt habe, weil ich nicht weiterkam, war die Ernüchterung groß, dass auch der 3. Raspi-3B+ nicht funktionierte.
    Überall findet man nur die Hinweise auf die Stromversorgung. Extra Netzteil gekauft – Fehlanzeige, auch damit gab es nur den mittlerweile verhassten Blink-Code. Bin hier vor Ort bei 3 Elektronik-Händlern gewesen und weitere Netzteile probiert. Nichts half. Zum Glück habe ich heute hier den entscheidenden Hinweis auf das falsche Image gelesen. SD-Karte mit neuem Image ausgestattet: ES FUNKTIONIERT.
    Ich war schon ’so‘ knapp vorm Aufgeben. Vielen Dank !!

CS · 4. März 2019 um 8:31

Hallo WP,

wenn die rote LED anfängt mit blinken ist es in den meisten Fällen die Spannung. Bisher habe ich das noch nie erlebt oder gesagt bekommen, dass die rote LED nur 4x blinkt. Bist Du Dir sicher, dass es die rote und nicht die grüne LED ist?
Die grüne LED kann nach verschiedenen Mustern blinken. Hier die Bedeutungen:
3x blinken: start.elf nicht vorhanden
4x blinken: start.elf nicht gestartet (SD-Karte kann auch defekt sein)
7x blinken: kernel.img nicht vorhanden
8x blinken: SDRAM nicht erkannt. Evtl. hilft ein Update der bootcode.bin oder start.elf

Gruß Christian

    Alfred0738 · 5. März 2019 um 17:48

    Ich kann es bestätigen.
    Habe bisher 2 Raspberry PI3 B im Einsatz und mir nun einen PI3 B+ bestellt der heute ankam.
    Ich habe extra ein 3.000 mA Netzteil dazu bestellt. Als ich ihn vorhin mit der SD-Karte die ich schon für die anderen beiden benutzt habe in Betrieb nehmen wollte, wurde der Bildschirm schön Bunt, wie es sein soll. Aber mehr passierte nicht. Nach einer Weile bemerkte ich das die rote LED blinkte, und zwar 4xlang, 4 x kurz, 1x sehr lang. Dann wieder von vorne.

    Auf der Suche nach der Bedeutung stieß ich auf diese Seite und habe mächtig geflucht, weil ich ja extra ein 3.000 mA Netzteil bestellt hatte. 🙁

    Also ein Netzteil der anderen beiden angesteckt.

    Ergebnis: Das gleiche. 🙁

    Also noch mal auf diese Seite, weitergelesen und auf den Beitrag von WP vom 1. März 2019 um 11:09 gestossen.

    Daraufhin habe ich von hier: https://www.raspberrypi.org/downloads/raspbian/
    eine aktuelle Version gezogen und mittels Etcher auf die SD-Karte gebrannt.

    Rein in den PI3 B+ und er ist gestartet. 🙂

      CS · 6. März 2019 um 6:51

      Hallo Alfred,

      ok, dann danke für die Bestätigung. Ich habe den Beitrag oben entsprechend aktualisiert. Danke für die Infos WP und Alfred.

      Gruß Christian

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Translate »